DSGW-030 MQTT Publish every 5seconds

Hi !

I am here because I am using a DSGW030-1 like zigbee gateway and every 5 seconds the gateway send the following message via MQTT:

{“to”:“CLOUD”,“from”:“GATEWAY”,“type”:“registerReq”,“data”:{“mac”:“30:ae:7b:e2:e5:99”,“license”:“dusun”,“factory”:“dusun”},“time”:1707742523,“deviceCode”:“”,“mac”:“30:ae:7b:e2:e5:99”}

Can someone help me? Is it possible to tell the gateway to stop sending that message?

On the other hand, is there a way to specify which topic to send messages to on each device?

Thank you!

This will happen until you send a register response and include a device ID. Once the gateway has a device ID it will stop this. The Dusun documentation should give you the format of the register response message.

HI! Thanks for your response. I imagined that this behavior was for that reason but I don’t know how to answer that it is registered, where should I do it? In the documentation for MQTT only put this:

“5.1.8. MQTT
The gateway supports the MQTT protocol for cloud connectivity.”

:sweat_smile:

Thanks men!

Here’s the documentation for mqtt message format. (section 5.1)

You should publish this messages on a mqtt client.
Zigbee2Mqtt of Dusun Gateway v2.2.pdf (2.5 MB)

Thank you! This is just what I needed! Also I have a problem with WiFi connection. When I connect to my router via ethernet everything it’s OK but I can’t connect the device to the WiFi network. I tried through LuCI interface in WiFI Settings but doesn’t work.