Unable to login into the firmware after installing the packages

I have loaded the firmware into px30k using the android tool.
Now it has the auto-login as a root user and debugging through debug serial port.

I have made sudo apt udpate and sudo apt upgrade, and rebooted the system.
Now its asking for password.

I tried root, root but didnt worked, and also its saying no user found with root.

Any assistance is highly appreciated.


the password may be different

Thank you for the password, but
the problem is when we type the username as root, then it is throwing error as no user found with that login.
Can you help me with this, what can be the username.

basically upgrade won’t cause this problem
have you done any other operations?

no just the apt update and apt upgrade with sudo.
now when we login with the root, we are getting problem with password.
and still not fixed

have you tried to re-flash the firmware?

yes, we did that, and also not able to access ssh either as password is not working.

have a try with this:

  1. connect the OTG port to your PC, the Android Tool may recognize it as an adb device
  2. install adb shell on your pc
  3. use adb command to connect to the device
  4. type the following commands:
echo 'PermitRootLogin yes' >> /etc/ssh/sshd_config
passwd root

we have created a new user, in that way we are able to login with the new user, by giving the sudo permissions to the new user.

We also would like to know , we are building the IOT camera application, and using IMX708 sensor camera.
Does this board, or firmware from dusun supports, this camera sensor, and if not what are the available options for me,

Could you also let us know how to access the camera. for this firmware.