Problem with DSGW-210 - Yocto image

We tried to install our own image on DSGW-210 generated with Yocto, but it failed. Now we can’t access anything. We don’t know how to restore the bootloader.

We can access the UART and capture this log:

�DDR version 1.19 20211011
ID:0x805 N
Bus Width=32 Col=10 Bank=4 Bank Group=2 Row=16 CS=1 Die Bus-Width=16 Size=2048MB
Boot1 Release Time: May 13 2019 17:34:36, version: 2.50
ChipType = 0x11, 248
SdmmcInit=2 0
FwPartOffset=2000 , 2000
SdmmcInit=0 1
StorageInit ok = 24775
Raw SecureMode = 0
SecureInit read PBA: 0x4
SecureInit read PBA: 0x404
SecureInit read PBA: 0x804
SecureInit read PBA: 0xc04
SecureInit read PBA: 0x1004
SecureInit ret = 0, SecureMode = 0
atags_set_bootdev: ret:(0)
GPT part:  0, name:            uboot, start:0x4000, size:0x2000
GPT part:  1, name:            trust, start:0x6000, size:0x2000
GPT part:  2, name:             boot, start:0x8000, size:0x447ize:0x3a2dfdf
find part:uboot OK. first_lba:0x4000.
find part:trust OK. first_lba:0x6000.
LoadTrust Addr:0x6000
No find bl30Load uboot, ReadLba = 4000
Load OK, addr=0x200000, size=0xedcb8
RunBL31 0x40000
INFO:    Preloader serial: 2
NOTICE:  BL31: v1.3(release):5315ffb0a
NOTICE:  BL31: Built : 10:45:58, Oct 19 2021
NOTICE:  BL31:Rockchip release version: v1alized
INFO:    Using opteed sec cpu_context!
INFO:    boot cpatus 0xe
INFO:    BL31: Initializing runtime services
INFO:   INF [0x0] TEE-CORE:init_primary_helper:337: Initializing (1.1.0-266-gee81607c #3 Mon Aug 17 09:29:38 UTC 2020 aarch64)

INF [0rimary_helper:338: Release version: 1.4

INF [0x0] TEE-CORE:init_teecore:83: teecore inits done
INFO:    BL31: Preparing for EL3 exit to normal world
INFO:    Entry point address = 0x200000
INFO:   3c9

U-Boot 2017.09 (Apr 03 2023 - 06:43:01 +0000)

Model: Rockchip RK3328 EVB
PreSerial: 2, raw, 0xff130000
DRAM:  2 GiB
Sysmem: init
Relocation Offset: 7da76000
Relocation fdt: 7bc6b4a8 - 7bc6cce2
Using default environment

DM: v1
rk3036_pll_set_rate: wait pll lock timeout! pll_id=4
rk3036_pll_set_rate: wait pll lock timeout! pll_id=2
rksdmmc@ff500000: 1, rksdmmc@ff520000: 0
Bootdev(atags): mmc 0
MMC0: High Speed, 52Mhz
PartType: EFI
No misc partition
boot mode: None
RESC: 'boot', blk@0x0000c398
optee api revision: 2.0
TEEC: Waring: Could not find security partition
Device is: UNLOCKED
DTB: rk-kernel.dtb
rockchip_inno_phy_hdmi_bind: no subnode for hdmiphy@ff430000
Error binding driver 'inno_hdmi_phy': -6
Some drivers failed to bind
rk3036_pll_set_rate: wait pll lock timeout! pll_id=3
rk3036_pll_set_rate: wait pll lock timeout! pll_id=3
I2c1 speed: 100000Hz
PMIC:  RK8050 (on=0x10, off=0x00)
vdd_logic 1100000 uV
vdd_arm 1100000 uV
Warn: can't find phy driver
Could not find baseparameter partition
Model: Rockchip RK3328 EVB
Rockchip UBOOT DRM driver version: v1.0.1
hdmi@ff3c0000 disconnected
CLK: (sync kernel. arm: enter 600000 KHz, init 600000 KHz, kernel 0N/A)
  apll 400000 KHll 1200000 KHz
  gpll 491009 KHz
  npll 600000 KHz
  armclk 6000 KHz
  aclk_peri 150000 KHz
  hclk_peri 75000 KHz
        Hit key to stop autoboot('CTRL+C'):  0
Could not find misc partition
ANDROID: reboot reason: "(none)"
Not AVB images, AVB skip
Booting IMAGE kernel at 0x00280000 with fdt at 0x08300000...

Fdt Ramdisk skip relocation
No misc partition
## Booting Android Image at 0x0027f800 ...
Kernel: 0x00280000 - 0x00af2315 (8 0x08300000
   Booting using the fdt blob at 0x08300000
   XIP   kernel loaded at 0x00280000, end = 0x00af2315
   Using Device Tree in place at 0000000008300000, end 00000000083156fd
failed to reserve drm-cubic-lut memory
Adding bank: 0x00200000 - 0x08400000 (size: 0x08200000)
Adding bank: 0x0a200000 - 0x80000000 (size: 0x75e00000)
== DO RELOCATE == Kernel from 0x00280000 to 0x00200000
Total: 458.904 ms

Starting kernel ...

"Synchronous Abort" handler, esr 0x02000000

* Reason:        Exception from an unknown reason
* PC         =   ffffffff8278a004
* LR         =
* SP         =   000000007bc6a2e0
* ESR_EL2    =   0000000002
x0 : 0000000008300000 x1 : 0000000000000000
x2 : 000000000000x4 : 00000000e400f000 x5 : 0000000000000001
x6 : 0000000000000007bc6a468 x9 : 0000000001008000
x10: 00000000ffffffd0 x11: 00003: 000000007bc6a3bc
x14: 0000000008300000 x15: 00000000000000020af2404
x18: 000000007bc6dcf0 x19: 0000000000000400
x20: 00000x22: 0000000000000004 x23: 000000007bc6a668
x24: 000000007bc6a6: 0000000000000000 x27: 0000000000000400
x28: 0000000000000000 : [< ffffffff8278a004 >]
  LR: [< 00201db4 >]

[< ff0216c88 >]
[< 002268fc >]
[< 002275d0 >]
[< 002076c8 >]
[< 00215114 >]
[< 00214864 >]
[< 00214e18 >]
[< 00215114 [< 002157b4 >]
[< 00213660 >]
[< 00215e2c >]
[< 0027a4b8
Copy info from "Call trace..." to a file(eg. dump.txt), and dump.txt

Resetting CPU ...

### ERROR ### Pleas

We are trying to restore the original image, but it’s not working. We can’t install either the original Dusun image.

Hi, can you assess into the maskroom mode?


We have already tried it previously!

Can you send it back to us, please contact your sales.


How can I access Maskroom?

I can’t find any schematic to short this.

Pressing the power button and the plug-in the usb-c power cable, it should access into maskroom mode